FineUI 官方论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

本论坛已关闭(禁止注册、发帖和回复)
请移步 三石和他的朋友们

FineUI首页 WebForms - MVC & Core - JavaScript 常见问题 - QQ群 - 十周年征文活动

FineUI(开源版) 下载源代码 - 下载空项目 - 获取ExtJS - 文档 在线示例 - 版本更新 - 捐赠作者 - 教程

升级到 ASP.NET Core 3.1,快、快、快! 全新ASP.NET Core,比WebForms还简单! 欢迎加入【三石和他的朋友们】(基础版下载)

搜索
查看: 6234|回复: 4

关于 FineUI 与 jQuery 兼容问题

[复制链接]
发表于 2017-9-18 22:03:13 | 显示全部楼层 |阅读模式
在 f.js 中添加了jQuery v1.12.4代码,这个造成和 jQuery 3.0 的版本兼容问题。而且对 jQuery 对象的重新定义。这个应该怎么处理?
发表于 2017-9-19 09:30:26 | 显示全部楼层
建议百度下 jquery 版本冲突解决。
发表于 2017-9-19 09:41:36 | 显示全部楼层
还有jquery-migrate 兼容jq库,我不确定是否对jquery3好用,试试吧
 楼主| 发表于 2017-9-19 15:45:53 | 显示全部楼层
zy32002 发表于 2017-9-19 09:41
还有jquery-migrate 兼容jq库,我不确定是否对jquery3好用,试试吧

谢谢!我加入了 jquery-migrate 的兼容库,才会出现问题,不加入到是正常的。不过我想请问一下 f.js 中为什么包含 jquery 1.14.1 的内容?就是这里面包含的这个存在问题,用 f_nojq.js 同样也不行。回头我把问题再现出来截图贴上来。
发表于 2017-9-19 16:57:35 | 显示全部楼层
lishan_work 发表于 2017-9-19 15:45
谢谢!我加入了 jquery-migrate 的兼容库,才会出现问题,不加入到是正常的。不过我想请问一下 f.js 中为 ...

先引用 jQuery3.0,在引用 f_nojq.js ,这样应该就好了。

FINEUI JS包含 jQuery 1.x 是为了兼容低版本 IE 浏览器,比如 IE8,IE9
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|FineUI 官方论坛 ( 皖ICP备2021006167号-1 )

GMT+8, 2022-12-8 17:38 , Processed in 0.076466 second(s), 18 queries , Gzip On.

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表